bundle install が出来なかった時の対処

エラーがえてbundle installができず。

バージョンはrbenvでいれた1.9.3-p392をつかって、Rails 3.2.12なんですが、エラーは下記のような感じ。

$ sudo bundle install
Unfortunately, a fatal error has occurred. Please see the Bundler troubleshooting documentation at http://bit.ly/bundler-issues. Thanks!
/Users/daddy/.rbenv/versions/1.9.3-p392/lib/ruby/gems/1.9.1/gems/bundler-1.3.0/lib/bundler/vendor/net/http/persistent/ssl_reuse.rb:70:in `connect’: SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (OpenSSL::SSL::SSLError)

どうも通信できないって言っているようです。
こんなときに調べてみたら、やっぱり対処法はだれかがブログに書いているもので、
こちらを参考にさせて頂きました。

対処法は簡単で、Gemfileの先頭の方にある
source ‘https://rubygems.org’ を source ‘http://rubygems.org
に書き換えるだけ。
SSL通信から普通のHTTPにもどしてやるんですね。
トラブルシューティングということで、またやりそうなのでメモメモ。

You Might Also Like

コメントを残す

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください